We're changing our website design on 27 August 2017.

Supported browsers for online accounts

Your computer or device should use the latest internet browser. This helps you to access our online accounts. It also increases your online security.

To use myGov, your browser needs to meet the myGov browser requirements.

To use our online accounts you need:

  • Microsoft Internet Explorer 9+
  • Mozilla Firefox 30+
  • Google Chrome 39+
  • Apple Safari 5+ (Apple only)

You must have cookies and JavaScript enabled in your browser.

With a mobile device, you can access your online account using our Express Plus mobile apps.

We’re testing a new website design. Try it out and tell us what you think. Read more about changes to this site.

Page last updated: 21 May 2017