Browser requirements - Online claiming for aged care providers

You’ll need to use an Internet Explorer or Chrome browser. The minimum browser requirements are:

  • Internet Explorer 9+
  • Google Chrome version 29+.

Internet Explorer 8 and below aren’t supported. You may find other browsers will work, however they’re not tested and aren’t supported.

Your browser needs to allow Secure Sockets Layer (SSL), cookies and JavaScript. Most browsers come with SSL, cookies and JavaScript turned on. If you need to change these settings, go to your browser’s help function.

Page last updated: 8 January 2019